	Practical 1



Introduction to QGIS

	Learning outcomes:
	
	Tools & techniques:

	Be able to set up QGIS and add data (p. 1)
	
	QGIS (p. 1)

	Join tabular data to spatial data (p. 4)
	
	Joining data (p. 4)

	Understand how to undertake simple calculations (p. 6)
	
	Adding a new field (p. 6)

	Understanding how to classify data for representation on a map (p. 7)
	
	Classifying and symbolising data (p. 7)

	
	
	Excluding missing data (p. 8)



1. Introduction and Setup

This practical is an Introduction to using QGIS. Anyone can download it from the Internet and it works on a wide range of machines including Windows, Ubuntu and Mac. QGIS is consistent with the principles of Windows software, so if you are familiar with programs such as Word or Excel you should find that similar concepts apply. Several conventions have been adopted in the following instructions:
· Bold type indicates software commands, options or window names (e.g. Open, Delete etc.)
· Italics are used to emphasise important points 
· A courier font is used for folder, file or program names (e.g. world_countries)
· Accessing a command or option through a sequence of menus or tabs is shown as: 
View > Zoom Data > Full Extent
Many commands require the OK button to be clicked or the Enter key to be pressed after a name has been typed in or an option selected. This step is assumed in what follows, with clarification only the first time a command is used or where the procedure is complex.
 
If necessary, switch on your PC and monitor. When the initialisation has finished, press the Ctrl – Alt – Delete keys to begin, and log on to the system. The next thing to do is to download the necessary data files for this practical to a directory on the hard disc of your PC (we will use My Documents). 
· Open My Documents and create a new folder named GIS. 
· Open this folder and create a new folder called prac1. This is where we will be storing all of the data that we copy and create during this practical session.

As there are several files they have been compressed into a single zip file, and you will need to first copy this and then extract the data files. Follow the instructions on screen to download the zip file from:
· bit.ly/1Bgapga or www.dropbox.com/s/nw3ty5mfod8sug2/prac1.zip?dl=0 

2. Starting up QGIS
· Start QGIS by navigating to: Start > All Programs > QGIS Brighton > QGIS Desktop 2.6.0
· If you get a QGIS Tips window (see below) you can tick the “I’ve had enough” tickbox to stop it opening every time you run QGIS.
[image: ]
Let’s start off by adding data to the map display. 
· Start by clicking the Add Vector Layer [image: ] button
· Then choose Browse and navigate to My Documents\GIS\prac1 folder
Change the option in the drop down menu on the bottom right to ESRI Shapefiles (*.shp *.SHP). Select the world_countries.shp file, click Open and click Open again. 
· This will add a layer which shows the countries of the world. 
QGIS has a number of different ways of navigating around spatial data. Click on the Zoom In tool [image: ] and draw a box around Europe – the display will zoom in to show this area. To view all of the data, click the Zoom Full tool [image: ].
Use the pan map tool to move around the map by clicking on the tool [image: ] and then click and drag around the map. You can also use the mouse wheel to zoom in and zoom out.  Experiment with the zoom and pan tools, and when you are happy, move on to the next section of the practical. 

This is where the on screen demonstration ends. Carry on with the practical instructions below.

The identify features tool [image: ] allows you to select a country on the map and see the attribute information stored in the shapefile about that country. 
· Select the identify features tool [image: ], and then click on a country. 
· A window will appear, titled Identify Results, with information about the country you selected. You may need to expand the window to see more of the details. 
· Try selecting different countries, to see how the tool works. 

When we added the world_countries shapefile, QGIS randomly assigned a colour. We can change this to something more sensible – green, for instance. 
· Right click on the world_countries entry in the layers window on the left hand side of the screen, and click on Properties:

[image: ]

· This will open the Layer Properties window, where we can change many different options for how the layer is displayed, as well as other options about the layer. 
· Click on the Style option on the left hand side.
· To change the colour, click on the drop down menu next to the color option: [image: ]
· You can then either select one of the preset colours, or click on Choose color… and select a colour from the color picker. Use either option, and change the colour to something you like. 
· Click Ok (and Ok again if necessary) and this will close the Layer Properties window and update the colour on the map. 

The options you have in this layer will depend on what type of spatial data you are dealing with. The countries layer is a polygon layer, so we can change the colour of the polygons. Point layers or line layers will have different options. Try experimenting with different colours, and other options in the Style section of the Layer Properties window. 

You may have noticed that when QGIS started, there were lots of toolbars and windows on display. It’s helpful to tidy this up a bit so we only have the buttons on display that we need.

· Right-click on the toolbar (grey area at the top) and you should see something similar to the menu below:

[image: ]

· You can click different toolbars on/off by checking their checkbox [image: ]. Spend some time turning the toolbars on/off to see what the different options do. Once you are finished, leave the following toolbars with their checkboxes checked [image: ]: Layers; Attributes; File; Label; Manage Layers and Map Navigation

This is a basic set of tools to get you started; we will turn on others as we require them. 

· You can also use the handle on each tool bar to drag the toolbars around and arrange them as you wish:

[image: ]
You should now have a big empty space with a few toolbars.  Once you have done this setup phase, QGIS should remember it, but if you use the software on a different computer you may need to follow these instructions again.

Using the same process as previously (Add Vector Data > Browse > …) add three more shapefiles to the map. The files to add are:  world_deg30.shp, world_lakes.shp and world_rivers.shp shapefiles. To select multiple files, select the one at the top of the list, hold down Shift on the keyboard and click on the bottom file. 

QGIS will add the layers, and again assign a random colour. However, you may not be able to see all the data. This is because the order of the different layers in the Layers window is important. 

· Re-order the layers (by dragging them up or down) so they are in this order (from top to bottom):  world_lakes, world_rivers, world_countries and world_deg30.
· Now you should be able to see the three different data sets. We can rename the layers as well – right click on world_deg30 and select rename. Rename this layer to Oceans and press enter. 
· Also use the Identify Features tool to investigate some of the new data layers. 
· Now is a good time to save the QGIS project file. Select Project > Save and save the file somewhere sensible. 

The colours of the different layers will also need to be changed, so update the colours to reflect what the layers represent. Remember also to save the project file!

3. Adding point data from a delimited CSV file

We have already added polygon data and line data, and now we are going to look at adding some point data. Open up the world-cities.csv file included in the zip file – it should open in Excel. You can see the file contains four columns: Name, Latitude, Longitude and Country. As this data has some coordinates, QGIS can plot the data on our map. Close the file (without saving, if Excel asks), and return to QGIS. 

· Click Layer > Add Layer > Add Delimited Text Layer… and click Browse and select the world-cities.csv file. 
· You should see the different columns appear at the bottom of the window. 
· Make sure that File format is set to CSV and Geometry definition is set to Point coordinates.
· Check that X field is set to Longitude and Y field is set to Latitude.
· Click OK.
· Depending on the settings, QGIS may ask what coordinate system the coordinates are in. Make sure WGS 84 (EPSG:4326) is selected, and click OK. 

You should now see the 15 cities added to the map. Update the symbols to a colour that fits in with your existing map. 

4. Joining tabular data

We only need the world_countries layer for the next exercise, so turn all of the other layers off by clicking on the check box next to each layer entry in the Layers panel. 

Not every dataset you want to use comes as a Shapefile or in a spatial format (in fact, the majority do not!). Often data will be in the format of a report, spreadsheet or table that you need to link to your existing spatial data for use in some analysis. For example, you may be working with population data for a country where the data is in a table, csv, Excel file (.xls, .xlsx), or any other non-spatial format. To map this data, you have to merge this with a Shapefile containing country boundaries. This operation is known as a Join and this section will cover how to carry out table joins in QGIS. To demonstrate this we will join a table of updated population data to our world_countries layer. 

In order to join tabular data it is necessary that both of your datasets have a common attribute (e.g. a name, unique reference or code). This attribute must be unique (i.e. a country must not be listed twice in your Attribute table) and identical (i.e. the country names must be the same and spelt identically, e.g. “Gambia, The” and “The Gambia” will not join successfully).

· Open the Attribute table of the world_countries layer and you’ll see that the NAME field is unique (different) for each country. 
· Close the Attribute table.
· In the data files that you copied today you’ll notice that there is also an Excel file named pop.xls. Double-click this file and it should open in Excel. The dataset contains two fields, a unique identifier called NAME and the other named POP_2011. Close the Excel file once you have finished viewing the data.

Now that we’ve identified the two fields in our datasets that we will use to make the join we can move on. 

· Confusingly, to add our table to the map we need to use the Add Vector Layer [image: ] button. Click on this now and Browse to the prac1 data files. Select pop.xls (if it doesn’t show, change the box next to File Name from ESRI Shapefiles to All files) and click Open, and click Open again to add the table of updated population data to the map project
· The table will now appear as a layer in the Layers window:

[image: ]

· Right-click on the table and Open Attribute Table to check that the data appears correctly (if you have <null> values there has been a problem importing your data (try removing it from the Layers window and add it again. If it doesn’t work, ask for help)). You should see both fields with data populated, row 0 containing Afghanistan with a population of 25500 (‘000s people). Close the attribute table when you finished viewing the data
· Now we will join this table layer with your spatial data. Right-click on the world_countires layer, select Properties and click on the Joins option
· Click on the plus [image: ] button to create a new join. The Add Vector Join dialogue box will now open
· Make sure that pop_2011 is selected in the Join layer dropdown box
· NAME should be selected in the Join field dropdown box
· NAME should also be selected in the Target field dropdown box

 (
The field in the spatial data that you will join to
) (
The field in the table that you will use to join the spatial data
) (
The table you want to join
) [image: ]

· Hit OK on the Add vector join window and also in the Layer Properties window
· Open Attribute Table of world_countries and you will see that a new field (named pop_2011_pop_2011) has been added to the Attribute table! Please ask for help if this is not the case.

The join that we have made is not permanent; it is a temporary link between the two datasets. To make the Join permanent we need to save a new copy of the world_countries layer.

· Right-click world_countries and click on Save as
· In the Save vector layer as window make sure that the following variables are selected:
· Format is ESRI Shapefile
· Save the new layer as world_countries_updated in the prac1 folder (click Browse to select the folder)
· Leave all other fields as they are
· Check the checkbox next to [image: ] Add saved file to map
· Hit OK and the new layer will be added to the map. Open the attribute table to check that the new field (pop_2011_pop_2011) is present. 
· Right-click world_countries and select Remove
· If you like, Save [image: ] your project

5. Adding a new field and calculating values

We will now add a new field to the attribute table and calculate some values (the change in population between 2004 and 2011) using a simple mathematical operation. This can be useful when you want to create new data or undertake some analyses.

· We need to add an extra toolbar for this – right click in the grey section at the top of the window, and select the Digitizing toolbar. A new toolbar will appear. 
· Click once on world_countries_updated in the Layers (Table of Contents) window and click on the Toggle editing mode [image: ] button
· Open Attribute Table of world_countries_updated
· Click on New column [image: ] button
· Set Name to POP_DIFF
· Leave Comment blank
· Set Type to Whole number (integer), change Width to 10.
· Hit OK

In this instance we are dealing with whole numbers, so we can use the integer setting. If we were calculating something else (for example, % population change) which involved decimal numbers, we would need to select: 
Decimal number (real), and set Width as 10 and Precision as 2.

You will see that the new field contains values, by default, as NULL. We now need to populate this new field (column) with some data.

· Click on the Open field calculator [image: ] button and the Field calculator window will open. It is here that we can undertake all manner of mathematical calculations
· Check the checkbox next to [image: ] Update existing field and select the field named POP_DIFF from the dropdown box
· Under the Function List group click on the expand plus sign next to [image: ] Fields and Values
· Double-click the field named pop_2011_p to add it to the Expression (the full name of the field has been cut off)
· Now click on the minus (-) sign and double-click on POP2004. Your expression should look like this: "pop_2011_p" - "POP2004" (notice how the expression builder puts in the double quote marks for you)
· Hit OK to run the calculation and the POP_DIFF field will populate with the calculated values (the first few values should be 75, 632 and 5644, for Luxembourg, Switzerland and France respectively, ask if this is not the case)
· Finally, click on the Toggle editing mode [image: ] button and choose Save when prompted. Close the attribute table
· Save [image: ] your project.

By the time you get to this section, we should have completed the ‘Classification Exercise’ worksheet. If we haven’t yet, please let me know that you have reached this point. 
6. Classifying Population Change

Now we have calculated the change in population between 2004 and 2011, we need to display it on the map. 
· Open the Style section of the Layer Properties window.
· Where the option says Single symbol at the top, change this to Graduated. 
· A new set of options will appear below. There are a range of different options hers, which we will explore in a bit. For the moment, select the POP_DIFF field from the Column drop-down list. 
· The click Classify, you will see the 5 classes for this data set appear in the window. 
· Click OK, and QGIS will update the map. 
Now we have a map of population change. However, there are various thing wrong with it. What are they? Have a think, and then chat to your neighbour to see what they think might be wrong. 
There are a number of things you can change to alter the classification:
1. Try changing the classification method, The default is Equal Interval. How do the different methods change the classification of the data. Which is “right”?
2. Try changing the number of classes.
3. Try changing the colours used – how does this impact the message of the map?
Once you have finished, remember to save your QGIS Project. If you wish to open this up on another computer, you will need to copy the QGIS Project File (*.qgs) and the data files (everything you downloaded from the zip file). 
Many of the principles of using QGIS are the same in other GIS software, such as ArcGIS and MapInfo. You can apply the principles you learnt here into any other GIS software, but the location and the names of some of the features might be slightly different. 

7. Excluding Missing Values (optional exercise)

When you looked at the population change, you may have noticed some very large negative numbers. Look at the values for 2004 and 2011 – why do you think these occurred? 

The values of -99 that appear against certain countries in the data mean that data is not available for these countries. Why might this be? (think about which countries they are). 

We can ask QGIS to exclude these values from the map. 
· Open the Attribute Table for the world_countries_updated layer. 
· Click on the Select features using an expression button [image: Macintosh HD:Users:nickbearman:Desktop:Screen Shot 2014-11-10 at 12.23.43.png].
· Using the same principle as we used to calculate the population change, build up an expression to say select features where POP2004 does not equal -99 and where pop_2011_p does not equal -99.
· The expression should look like this: "POP2004" != -99 AND "pop_2011_p" != -99
· Click Select.
· The selection should be updated in the Attribute Table. Click Close to close the Select by expression window. 
· Now right-click on the world_countries_updated layer in the Layers window and choose Save As…
· Click Browse and provide a filename (world_countries_updated_excluded). Make sure you select Save only selected features otherwise we will end up with exactly the same set of countries!
· Press OK. 

Now we have removed the countries with the missing values. Repeat the classification process, and the classes produced should be more helpful. 

8. Classifying % Population Change (optional exercise)

What else might be wrong with the data we have calculated?

Currently we are comparing the increase in numbers of people between 2004 and 2011 in each country. It might make more sense to compare the % increase. Calculate this and then show this on a map. Why is this a more logical way of representing this data?
[bookmark: _GoBack]
[image: ]
Written and tested using QGIS 2.6 on 13/11/2014 by Nick Bearman. 
This work is licensed under the Creative Commons Attribution-ShareAlike 4.0 International License. To view a copy of this license, visit http://creativecommons.org/licenses/by-sa/4.0/deed.en. 
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